Criteria Your Browser Information Minimum Requirements Meets Requirements
keys
Browser

Version:

- FireFox 11 or 12
- Chrome 25


or
Download FireFox
(Win and Mac OS X)

or
Download Chrome
(Win and Mac OS X)
 
JavaScript Version
Version:
JavaScript 1.2
 
Cookies
Cookies Enabled
 
Flash Player

Version:
Adobe Flash Player 11.1 or 11.2

Download Adobe Flash Player
 
Shockwave Player
Version:
Adobe Shockwave Player 10 or 11

Download Adobe Shockwave Player
Download Adobe Shockwave Player for MAC
 
Acrobat Reader  
Adobe Acrobat Reader 9 or 10

You must manually verify your Acrobat Reader installation. Go to CompassLearning Odyssey Support and click the Acrobat Reader question for instructions.

Download Acrobat Reader
 
Java  
Java Virtual Machine 1.4.2

You must manually verify your Java installation.
Go here and follow the instructions.

Download Java Virtual Machine